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Introduction 
 
This document explains how to take advantage of the SOCKS server offered by the Opensky 
platform, by describing the configurations to be done in the most used applications. Opensky also 
offers an HTTP proxy, which is reccomended for normal web traffic (e.g. normal browsing). The 
exact address of both the HTTP and SOCKS proxies is shown after the “Satlogin” operation. This 
address depends on the user account properties; in the rest of the document, it is assumed that the 
address of the SOCKS server is “193.251.135.110”: please change it according to your parameters. 
 
In order to use the SOCKS server, usually you should configure properly your application. Notice 
that the SOCKS server is available only after the “Satlogin” operation. In the first part of the 
document, the setup procedure is described for most applications which support SOCKS servers. 
 
In the second part of the document, the use of some “socksifying” tools will be described. These tools 
allow to use SOCKS server within some applications which do not directly support SOCKS. Notice 
that these tools are not part of the Opensky distribution, nor they are endorsed by EUTELSAT by any 
means. They are described here only for user convenience, but any user should obtain them through 
appropriate channels, and install and use them under his own responsability. 
 
 
Integrated Browser and Email/Newsgroup Clients: 
 
To setup Microsoft Internet Explorer (ver. 5.5) select Internet Options from the Tools menu, then 
select the Connections panel (Fig. 1): now select the Dial-up connection that is used for Opensky 
connections; click on the Settings button; a new window (Fig. 2) will pop-up and here select “Use a 
proxy server” and “Bypass proxy server for local addresses”; now click the Advanced button, another 
window (Fig. 3) will pop-up and here the OpenSky’s Proxy and Socks addresses have to be set. 
 

          
(Fig. 1)      (Fig. 2) 
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(Fig. 3) 

 
Note that if a server is specified for a particular protocol – i.e. a Proxy is set for the HTTP – the socks 
is bypassed and all the data (for that protocol) are received via the Proxy server. This is the 
reccomended configuration, as HTTP is more efficient than SOCKS for web-type traffic. 
 
 
Outlook Express (the Microsoft Email / Newsgroup client integrated in Windows) uses the Internet 
Explorer settings, however both e-mail and newsgroup messages will always be received via modem 
(both POP3 and IMAP protocols), bypassing the Socks settings. If you want to use Outlook Express 
with Opensky, you should use “socksfy” tools, as described in the second part of this document. 
 
 
To setup Netscape Navigator (ver. 6.02) and Mozilla (ver. 1.2) select Preferences from the Edit 
menu; now a new window (Fig. 4) will appear and from that select Proxies and then insert the 
OpenSky Proxy and Socks Server addresses. 
Note that if a server is specified for a particular protocol – i.e. a Proxy is set for the HTTP – the socks 
is bypassed and all the data (for that protocol) are received via the Proxy server. This is the 
reccomended configuration. 
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(Fig. 4) 
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Download Managers 
 
To configure FlashGet (ver. 1.3) select Options from the Tools menu, then select the Proxy panel 
(Fig. 5); now click on the Add button and insert the OpenSky Proxy (Fig. 6) or the Socks (Fig. 7) 
depending on which protocol has to be used. 
 

 
(Fig. 5) 

 

               
       (Fig. 6)       (Fig. 7) 
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To configure Getright (ver. 4.5d) select Getright Configuration from the Options menu, then select 
the Proxy panel (Fig. 8): insert the OpenSky Proxy (Fig. 8) or the Socks (Fig. 9) depending on which 
protocol has to be used. 
 

    
(Fig. 8)      (Fig. 9) 

 
 

 
FTP Clients 
 
To configure CuteFTP (ver. 4.2.5) select Settings from the Edit menu, then select the Socks panel 
(Fig. 10) where has to be set the OpenSky Socks address. 
 

 
(Fig. 10) 
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File Sharing Clients 
 
To configure WinMX (ver. 3.31) click the Settings button and select Outgoing TCP Connection: here 
insert the OpenSky Socks address (Fig. 11); in the Outgoing TCP Connection panel select Unable to 
accept incoming TCP connections (Fig. 12), in the In/Out UDP Packets panel select Unable to send 
and receive UDP datagram on any port (Fig. 13), in the Host name resolution panel select Use 
operating system to resolve host names (Fig.14).  
 

        
(Fig. 11)      (Fig. 12) 

 
 

       
   (Fig. 13)      (Fig. 14) 
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To configure Kazaa Lite (ver. 2.00) select Options from the Tools menu, then select the Firewall 
panel (Fig. 15) and here insert the OpenSky Socks. 
 

 
(Fig. 15) 
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Multimedia Players 
 
To setup QuickTime (ver. 6.0) select Preferences -> QuickTime Preferences from the Edit menu; 
now select Streaming Proxy (Fig. 16) and set the OpenSky Proxy; then select Streaming Transport 
and set Use HTTP, port ID 80 (Fig. 17). 
 

                       
     (Fig. 16)                   (Fig. 17) 
 
To setup Windows MediaPlayer (ver. 6.4) select Options from the View menu, then select the 
Advanced panel (Fig. 18): click on  the Change button and select HTTP, use Proxy (Fig. 19); click on 
the Configure Proxy Settings button and set the OpenSky Proxy (Fig. 20). 
 
                     
 
 
 
 
 
 
 
 
 
 
 
                            (Fig. 18) 
 
 
 
 
 
 
      (Fig. 20)              (Fig. 19) 
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To setup Real Player (ver. 8.0) select Preferences from the View menu, then select the Proxy panel 
(Fig. 21) and here insert the OpenSky Proxy; in the Transport panel select Use specified transports 
(Fig. 22): click on the RTSP Settings button and set Use HTTP only (Fig. 23), click on the PNA 
Settings button and set Use HTTP only (Fig. 24). 
 

                   
      (Fig. 21)                (Fig. 22) 
 
 
 

                   
       (Fig. 23)             (Fig. 24) 
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Chat Clients 
 
To configure Microsoft MSN Messenger (ver. 4.6) select Options from the Tools menu, then select 
the Connection panel (Fig. 25) and insert the OpenSky Socks. 
 

 
(Fig. 25) 
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Summary 
 

 
Application 

OpenSky 
Socks 

Support 

 
Notes 

Internet Explorer 
 

Yes HTTP, HTTPS and FTP protocols are 
supported 

Outlook Express 
Email/Newsgroup 

No  

Mozilla – Netscape 
 

Yes HTTP, HTTPS and FTP protocols are 
supported 

Mozilla – Netscape 
Email/Newsgroup Client 

Yes  

FlashGet 
 

Yes   

GetRight 
 

Yes   

CuteFTP 
 

Yes  

WinMX 
 

Yes   

Kazaa Lite 
 

Yes  

QuickTime 
 

No* *=Supported only for HTTP contents 

RealPlayer 
 

No* *=Supported only for HTTP contents 

Windows Media Player 
 

No  

Windows Messenger Yes The socks is used only for data transfers (files, 
chat, whiteboard) but not for audio or video. 
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HummingBird Socks Client (ver. 7.1) 
 
The HummingBird Socks Client makes “socks-able” most TCP/IP application (even the ones which 
doesn’t support the socks protocol) making possible the use of the OpenSky Socks in a transparent 
way for the user and offering the chance to use Internet applications that don’t support internally the 
Socks protocol with the Fast Internet Service provided by OpenSky. Notice however that some 
applications may not work properly is Hummingbird Socks Client is installed. 
 
The software can be downloaded from http://www.hummingbird.com/products/nc/socks/ (it is 
freeware for private use); it is also highly recommended to install the patch downloadable from 
ftp.hcl.com/pub/bbs/socks7101/hclsock5.zip.  
 
Patch installation: after installing the program you should substitute the file “hclsock5.dll” (ver. 
7.1.0.1) that comes with the software and that is resident in the folder: 

“C:\WINDOWS\system\Hummingbird\Connectivity\7.10\Socks” (for Windows ME) 
 “C:\WINNT\system32\Hummingbird\Connectivity\7.10\Socks” (for Win2000) 
“C:\WINDOWS\system32\Hummingbird\Connectivity\7.10\Socks” (for Windows XP ),   

with the file “hclsock5.dll”  (ver. 7.1.0.2) found in the file hclsocks5.zip previously downloaded. To 
obtain the version of a DLL file, right-click on its icon, and select the Version tab. 
 
In the same folder you fill find the configuration file “socks.cfg”: it is a plain text file (that can be 
opened with Notepad or with any other text editor) that contains the program settings; into that file 
the following lines are to be added: 
 
BIND-MODULE * 
DIRECT 193.251.135.66 255.255.255.255 443 
DIRECT 193.251.135.100 255.255.255.255 
SOCKD5 @=193.251.135.110:1080 0.0.0.0 0.0.0.0 
 
The first row specifies which services to make socks-able (‘*’ means all services), the second and the 
third rows specify the hosts that have to be reached without using the Socks  (in this case the host for 
satlogin/satlogout operations and the HTTP Proxy address: this one is to be preferred in applications 
that support the HTTP, HTTPS or FTP).  
Once saved the changes, close the file “socks.cfg” and then restart the Internet application to make it 
“socksfyied”. 
 
Notice that this software operates at the TCP stack level of your Windows machine. It is possible that 
it is in conflict with other TCP-related software, e.g. firewalls, anti-virus, network performance tools, 
etc. 
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Applications tested with the HummingBird Client and the OpenSky 
service 
 
 

 
Application 

Right 
behaviour 

 
Notes 

Internet Explorer (5.5) 
 

Yes  

Outlook Express (5.5) 
Email/Newsgroup 

Yes  

Mozilla (1.1)  
Netscape (6.02) 

Yes  

Mozilla – Netscape 
Email/Newsgroup 

Yes  

Eudora Email Client 
(5.1.1) 

Yes  

Opera (6.03) 
 

Yes   

FlashGet (1.3) 
 

Yes   

GetRight (4.5d) 
 

Yes   

BulletProof FTP (2.4) 
 

Yes  

CuteFTP (4.2.5) 
 

Yes  

WinMX (3.31) 
 

Yes   

SSH Secure Shell (3.2) 
 

Yes  

QuickTime (6.0) 
 

No Supported only for  HTTP contents 

RealPlayer (8.0) 
 

No Supported only for  HTTP contents 

Windows Media Player 
(7.1) 

No Supported only for  HTTP contents 

mIRC (6.02) Yes  
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SocksCapV2 Client (version 2.32-021231) 
 
 
The SocksCapV2 makes “socks-able” any TCP/IP application (even the ones which don’t directly 
support the socks protocol) making possible the use of the OpenSky Socks in a transparent way for 
the user and offering the chance to use Internet applications that don’t support internally the Socks 
protocol with the Fast Internet Service provided by OpenSky. 
The program may be downloaded from  http://www.socks.nec.com  (freeware for private use). 
It is possible to setup the application selecting Settings from the Files menu: then is just needed to set 
the OpenSky Socks Server address (Fig. 26). 

 

 
(Fig. 26) 

 
 

In the Direct Connection panel (Fig. 27) is possible to set the addresses that have to be reached 
directly, without using the socks; in this case has been specified the host that contains the 
satlogin/satlogout page and the Proxy Server address: this one is to be preferred in applications that 
support the HTTP, HTTPS or FTP protocols so in the Internet applications to be used is suggested to 
use the Proxy if supported). 
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(Fig. 27) 

 
 

Now to make socks-able an application just drag the icon used to launch it over the SocksCapV2 
window. When the mouse will reach the window a menu will appear from which is possible to 
choose to start the selected application or to add it into the inserted profiles to make easier successive 
uses of that program; a SocksCap32 use example is showed in picture 28. 

 

 
(Fig. 28) 

 
 
 

Note that it is possible to IMPORT/EXPORT the settings of the program and of the socksfied 
applications using the Import Setting and Export Setting commands located in the Files menu.  
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Applications tested with the SocksCapV2 Client and the OpenSky 
service 
 

 
Application 

Right 
behaviour 

 
Notes 

Internet Explorer (5.5) 
 

Yes  

Outlook Express (5.5) 
Email/Newsgroup 

No  

Mozilla (1.1)  
Netscape (6.02) 

Yes  

Mozilla – Netscape 
Email/Newsgroup Client 

Yes  

Eudora Email Client 
(5.1.1) 

Yes  

FlashGet (1.3) 
 

Yes   

GetRight (4.5d) 
 

Yes   

BulletProof FTP (2.4) 
 

Yes  

CuteFTP (4.2.5) 
 

Yes  

WinMX (3.31) 
 

Yes   

SSH Secure Shell (3.2) 
 

Yes  

QuickTime (6.0) 
 

No Supported just for  HTTP contents 

RealPlayer (8.0) 
 

No Supported just for  HTTP contents 

Windows Media Player 
(7.1) 

No Supported just for  HTTP contents 

mIRC (6.02) Yes  
 

Windows Messenger 
(4.7) 

Yes The program makes a regular access to the 
service and the chat messages are received 
via socks but when sending files the receiver 
(that uses SocksCapV2) isn’t able to receive 
them. 

 


